3d printed columns are printing really bad (Prusa i3 – not ultimaker)

Hello, I’ve made a custom 3d printer from scratch, based on the prusa i3. I managed to calibrate everything as far printed walls are looking nice. I have two major problems with my printer.

Problem 1
One is that columns are printed terrible. Some are printed decent, others are printed like some hamster chewed on it. They have spiral effects. I can’t describe it in words so I’ll upload some images;

2016-03-06 13.45.03
2016-03-06 13.45.03
2016-03-06 13.45.47
2016-02-21 18.36.37

I can’t find lots of information about my problem, but Maker’s Muse from Youtube had similar spiral artifacts on prints using Cura and Simpify3D.

I’d really like to fix this…

Problem 2
Another problem is that my extruder motor (bowden setup) is making clicking noise and skips. When I hear the skipping / clicking noise, I look at the gear on the motor and it stops turning and then continues to turn. It doesn’t grind into the filament. This happens mostly only when printing the walls of the design when it prints faster than the infill.
– The screw holding the gear on the motor is tight and not moving
– The motor isn’t even warm, let alone hot
– The driver isn’t even warm, let alone hot (also using a fan on the board to keep it cold)
– Driver is the red pololu a4988, for the extruder the volt is set to 1.2v

Printer slicer
Cura 15.04.4

Print settings
– Layer height mm: 0.2
– Shell thickness mm: 1
– Enable retraction: speed 30mm/s, distance mm 2
– Bottom / top thickness mm: 1
– Fill density: 20
– Print speed mm/s: 25
– Travel speed mm/s: 60
– Bottom layer speed mm/s: 25
– Infill speed mm/s: 10
– Other speeds: same as print speed.
– Printing temp C: 260 (I only get good prints and sticking layers when printing at this temp. Any lower it gets worse
– Bed temp C: 110
– Platform adhesion type: raft
– Filament dia mm: 2.9 (fila is 3mm, but I measure 2.9 all across with a caliper)
– Flow: anywhere from 90 to 120
– Nozzle dia mm:  0.5

Printer setup
– Inductive sensors for bed leveling, auto bed level before every print
– Paper fits between nozzle and bed
– 12v 30A power supply
– Sanguinololu 1.3a
– red pololu a4988 (dvr8825 coming within a week)
– Printer covered in heat chamber
– Using ABS 3mm (which is 2.9mm)
– Latest marlin
– Nema 17 motors

Hope someone can help me out, the printer is making me nuts and I do not have 2k to spend on a nice Ultimaker 2 as a student.

Thanks!